icon-rss-large

中文泛技术类IT博客 | 留言

软路由 | 硬路由 | 网站地图 |

DDNS动态域名脚本(花生壳+3322公云)for ROS 6.x(转)

发表于 2016年08月28日 软路由版

一、花生壳
花生壳动态域名是全球用户量最大的完全免费的动态域名解析软件(DDNS)。当您安装并注册花生壳动态域名解析软件,无论您在任何地点、任何时间、使用任 何线路,均可利用这一服务建立拥有固定域名和最大自主权的互联网主机。“花生壳动态域名解析软件”支持的线路包括普通电话线、ISDN、ADSL、有线电 视网络、双绞线到户的宽带网和其它任何能够提供互联网真实IP的接入服务线路,而无论连接获得的IP属于动态还是静态。
现在花生壳动态域名解析软件为千万的域名提供动态域名解析服务,并广泛应用于网站建设、视频监控、遥感测绘、FTP、VPN、企业OA、ERP等应用领域。

脚本:

local ipaddr
local server “http://ddns.oray.com
local domain “域名”
local par “/ph/update?&hostname=$domain&myip=$ipaddr”
local users “用户”
local paswd “密码”
:set ipaddr [/ip address get [/ip address find interface=pppoe-out2] address]
:set ipaddr [:pick $ipaddr 0 ([len $ipaddr] -3)]
/tool fetch url=($server . $par) mode=http user=$users password=$paswd



二、3322

脚本:


:local ednsuser “用户”
:local ednspass “密码”
:local ednshost “域名”
:local ednsinterface “接口”
:local members “http://members.3322.org/dyndns/update?system=dyndns
#:local members “http://members./nic/update?”
:local status
:local status [/interface get [/interface find name=$ednsinterface] running]
:if ($status!=false) do={
:local ednslastip [:resolve $ednshost]
:if ([ :typeof $ednslastip ] = nil ) do={ :local ednslastip “0” }
:local ednsiph [ /ip address get [/ip address find interface=$ednsinterface ] address ]
:local ednsip [:pick $ednsiph 0 [:find $ednsiph “/”]]
:local ednsstr “&hostname=$ednshost&myip=$ednsip”
:if ($ednslastip != $ednsip) do={/tool fetch url=($members . $ednsstr) mode=http user=$ednsuser password=$ednspass dst-path=$ednshost
:delay 2
:local result [/file get $ednshost contents]
:log info ($ednshost . ” ” .$result)
/file remove $ednshost ;
}
}


本文标题:DDNS动态域名脚本(花生壳+3322公云)for ROS 6.x(转)
本文链接:http://www.sesaminkouka.com/index.php/post/920.html
作者授权:除特别说明外,本文由 citywo 原创编译并授权 大城小我 刊载发布。
版权声明:本文不使用任何协议授权,您可以任何形式自由转载或使用。
0
留言区
留言区

好运11选5 www.32169.com-go彩票的邀请码| www.dg29.com-福利彩票时时彩下载| www.837151.com-立彩彩票软件可靠吗| www.535090.com-新加坡六星彩官网| www.633550.com-99彩票网必中一肖| www.791744.com-博京娱乐平台时时彩| www.910112.com-粤彩联盟新版| www.993546.com-足彩购买时间| www.bq30.com-彩64-| www.b49.cn-奔腾彩票登录| www.60ve.com-国2元彩-| www.02vh.com-彩虹条头像同性| www.0151.org-北京福彩中奖规则| www.463609.com-体彩3d走势-| www.1315.org-彩票中奖几天兑换| www.10564.com-关小刀足彩任9预测| www.wj83.com-爱彩票官网-| www.562701.com-优乐彩可信吗| www.74qb.com-体彩什时间开始| www.3770.cc-体彩11选五规律| www.608259.com-彩票3d71期-| www.6cp.com-宏腾彩票网合买平台| www.85ja.com-体育彩票胜负彩预测| www.969928.com-中国福利彩票真实| www.cm55.com-江苏福彩快三技巧| www.1vq.com-时时彩多少分钟一期| www.65pa.com-博彩代理提成| www.2079.pw-老彩票正规的吗| www.7881.com-彩票开奖号码三d| www.1782.vip-上海基诺彩票走势图| www.01206.com-中国竞彩网触屏版| www.99595.cc-最近的体育彩票站| www.112041.com-彩票亿元大奖一览表| www.179201.com-百盈快三稳赚计划| www.086872.com-飞鱼彩票怎么玩法| www.090031.com-怎么寻找彩票客户| www.35oq.com-七星彩808胶版| www.7326.vip-彩虹系列无人机价格| www.740035.com-福利彩票几位| www.810802.com-天天体彩直播开奖| www.878224.com-福彩3d+开奖号| www.968737.com-现实中的彩神| www.bv56.com-彩票挂机app| www.xw54.com-335彩票官网| www.32py.com-长沙有人中彩票了| www.253.com-彩钢单板价格| www.4688.top-彩票跟那期好| www.qs3.cc-吉林市彩票兑奖地址| www.219981.com-中彩网快三走势图| www.302680.com-晴予七星彩预测| www.001577.com-贵州快三今日推荐号| www.120858.com-聊呗彩票群-| www.206496.com-鳄鱼彩票网-| www.849421.com-爱乐彩上海11选5| www.920412.com-彩票新闻网-| www.nc54.com-中彩福彩票软件| www.833787.com-福利彩票怎么自选| www.937173.com-五福彩676cc| 博友彩www.267by.com| www.402967.com-牛彩网七乐彩杀号| www.520617.com-红旗彩票投注站点| www.586507.com-金沙邀请码送彩金| www.669421.com-彩票有必要买吗| www.872093.com-铜仁福彩中心| www.16fx.com-七彩蓝田投资真假的| www.474890.com-五彩绳怎么编视频| www.634505.com-博大彩票软件| www.69my.com-区块彩票系统| www.567080.com-起了彩票大发快三| www.665428.com-彩78是正规彩票吗| www.733438.com-福建彩票网走势图| www.799648.com-内蒙快三49期下载| www.868168.com-重庆时彩开奖时间| www.928932.com-中福彩票黑平台| www.988667.com-微彩站app-| www.ba69.com-快三安徽-| www.6982.biz-领红包彩票网址| www.488628.com-51中彩可靠吗| www.807912.com-数字彩票预测法| www.906255.com-彩色的非洲-| www.974870.com-福彩一周开几次奖| www.ba3.com-福彩快3湖北结果| www.zu90.com-大有娱乐彩票平台| www.40to.com-七星彩购买网| www.6100.biz-釉上彩茶具安全吗| www.eo11.com-时时彩两顺一反倍投| www.n10.me-网上买彩票正规平台| www.670647.com-中润福利彩票| www.762775.com-小捣蛋走势图时时彩| www.843377.com-公益彩票玩法规则| www.903959.com-彩票游戏出租| www.962920.com-中国彩票双色球下载| 大赢家彩票平台www.253230.com| www.zw33.com-八面通七彩国际影城| www.22mz.com-吉祥彩票骗局| www.144734.com-竞彩足球单场分析| www.137617.com-帮黑客投彩票骗局| www.532892.com-河北快三手机版| www.607680.com-韩国彩票走势图| www.666363.com-乐彩网违法吗| www.727548.com-忆彩网-| www.792532.com-河源市福彩兑奖中心| www.967201.com-即时开彩现场| www.io0.cc-内蒙古福利彩票查询| www.po83.com-体彩票开奖31选7| www.597529.com-北京快三有啥规律吗| www.673963.com-彩画分类-| www.748378.com-993彩票软件| www.806607.com-有体彩彩票-| www.283763.com-体彩7星彩几点开奖| www.382307.com-博汇彩票最新消息| www.503255.com-特别快开奖的彩票| www.595048.com-福彩乐透乐博彩论坛| www.686263.com-中国体彩福彩| www.786928.com-彩票中奖指南百度云| www.862637.com-新浪网彩票开奖| www.948020.com-福彩公益金-| www.991958.com-彩票都那几个数号出| www.xw20.cc-彩6官网下载ios| www.25ho.com-华彩在线彩票app| www.331.cn-快三龙帽子啥意思| www.3879.top-好客彩aqq-| www.643768.com-竞彩奖金计算公式| www.739699.com-互联网彩票大整顿| www.853323.com-查查七乐彩开奖号码| www.939797.com-彩98网站-| 500万彩票www.35155x.com| www.ip39.com-共享彩票快三返点| www.wh57.com-内蒙古体彩-| www.09cu.com-河内彩票骗局| www.198493.com-七乐彩快三-| www.69kv.com-买彩票能戒掉么| www.0516.pw-彩票公益下载安装| www.7124.biz-体彩飞鱼游戏技巧| www.272758.com-江苏快三走势图牛| www.93847.com-七乐彩有什么秘诀| www.3110.me-江苏福彩快-| www.102166.com-彩神计划破解充钱| www.217779.com-爱刮刮自助彩票机| www.275283.com-彩票任三-| www.531114.com-天下彩彩票结果| www.603691.com-女性梦见买彩票| www.698976.com-零基础学彩铅方法| www.834892.com-绿好彩薄荷味| www.888117.cc-94彩票下载-| www.943679.com-重庆彩票网官网开奖| www.981334.com-贵阳省福彩中心| www.cp9708.com-彩之家app-| www.ni82.com-全天实时彩计划| www.8ln.com-凤凰极速快三网站| www.71lo.com-买彩票的打油诗| www.086555.com-开心彩票-| www.203443.com-福彩时时乐走势图| www.717985.cc-中国体彩报左木预测| www.803550.com-体彩大乐透查询器| www.875480.com-快钱彩票是真的吗| www.941456.com-彩票站经营思路| www.988680.com-73期期好彩-| www.yq4.com-玩彩正确倍投| www.pn58.com-湖北快三站点| www.28526.cc-全球官方彩票| www.019977.com-体彩网购-| www.98si.com-彩迷联销图-| www.1777.date-外围彩票怎么买|